This project has moved and is read-only. For the latest updates, please go here.

Invalid server's version string

Sep 21, 2009 at 10:44 AM
Edited Sep 21, 2009 at 12:04 PM

What is the meaning of this error? I've been able to communicate with the SFTP server for 3 months now, but suddenly this error occur. The administrators of the SFTP server have announced that they have some "issues" at the moment. Still, using a small client, a command line tool from Sterling Commerce, im able to connect and upload/download messages. In other words this small client tool ignores those "issues" at the SFTP server. As the error message implies it might has something to do with the version of the SSH protocol accepted/used by the server/client.

Doing af telnet command on the sftp server and port i receive the message: SSH-2.0-Connect:Enterprise_UNIX_2.4.02 - I guess that means that the ssh protocol accepts only 2.0 clients? Or how does all this come together? Thanks in advance.

Full error message:

Type: System.Exception
Message: Unable to connect to Sftp host [servername]

Type: Tamir.SharpSsh.jsch.JSchException
Target: Void connect(Int32)
Message: invalid server's version String
   at Tamir.SharpSsh.jsch.Session.connect(Int32 connectTimeout)
   at Tamir.SharpSsh.SshBase.ConnectSession(Int32 tcpPort)
   at Tamir.SharpSsh.SshBase.Connect(Int32 tcpPort)
   at Blogical.Shared.Adapters.Sftp.SharpSsh.Sftp.connect(Boolean force)


Sep 26, 2009 at 7:34 PM

We've had another issue similar to this one a couple of months ago. That time the problem was that the sftp header from the server had some empty lines which caused the adapter to look at the wrong place when trying to find the version number.

The good news is that this has been fixed in the latst release. Download it and try again.



Dec 31, 2010 at 2:18 AM


I have installed the version Blogical.Shared.Adapters.SFTP v1.4.0 Setup , and it was not working . The server team changed something and similar to situation berges ,( most probably IP Address), The SFTP adpater in biztalk keeps trying to connect , is not able , I have logged a message for the under seprate thread on this forum .

After 3 months i am not able connect ..where i was able to connect in perfect manner and do the transfer,  I tried the code referencing blogical.shared.adapters.sftp.dll as below from a console application and throws the same error invalid server's version String.

Any idea what could be the issue

 using (Sftp sftp = new Sftp(host, user, pass, keyfile, port, passphrase,true))