This project has moved and is read-only. For the latest updates, please go here.

can't see the port in my orchestration

Jun 8, 2009 at 9:08 PM


I'm having some trouble using this in my orchestration.  Here's what I've tried.  

1.  Within visual studio I tried creating a port and specifying the binding right away.  SFTP was not one of the choices when it came to transport. 

2.  I tried creating a port and choosing specify later.  After deploying, I go into the biztalk administrator console and see that my orchestration is not enlisted since ports have been left unbound.  Unfortunately, when looking at the list of receive ports, the one I set upto add receive locations, but the unbound receive ports don't show up in the admin console.


Within Biztalk administration I added the adapter and was able to configure a receive port to use a receive location that is using the sftp adapter so I know the installation went okay.

I feel like I'm missing a very simple step.  I'm new to biztalk in general and could be going about this entirely the wrong way.  Could someone give me a little guidance?


Jun 9, 2009 at 12:16 AM

Okay, I solved that problem.  It was a simple matter of going through the configure step of my application in the Biztalk Admin console.

The problem I'm having now is that nothing is happening.  I've placed a file on my sftp server and nothing seems to be happening.  The orchestration is running, but the file is never renamed and the other tasks that are part of the orchestration are never run.  I'm also getting nothing in EventViewer to indicate success or failure.  Am I looking in the wrong place perhaps?

Jun 9, 2009 at 11:14 AM


This is how I'd go about setting it up:

  1. First create a Receive Port and Location using the SFTP adapter.
  2. Create  a tempoary Send Port with a filter matching the Receive Port
  3. Test the solution, making sure the files are picked up. If you having problems, check out this post:
  4. Deploy your orchestration, without port bindings (allways a good practice)
  5. Delete the Send Port, and bind the orchestration to the Receive Port you created earlier.
  6. Start your Send Ports, start the orchestration and enable the Receive Location.

In my experiance, there is usually a bit tricky to get the SFTP communication up and running. This is not neccesary due to the adapter, but other factors such as autentication, identity files etc..




Jun 10, 2009 at 2:56 PM
Edited Jun 10, 2009 at 5:29 PM

Hi Mikael,

Thank you for answering my post.  I got up to step 2 and nothing seems to be happening.  I checked the logs on my sftp server and it seems that no attempts to log in have been made.  Looks like the scheduler isn't working right for me.  I have it set to execute every 2 minutes.  Was there a pre-requisite that I needed to install for the scheduler to work?

On a seperate note, should I be able to see errors in the Event Viewer?  After installation, I ran installutil on Blogical.Shared.Adapters.

Common.dll and I still don't see anything when going to event viewer.  I also set Trace to true in the receive location configuration.


Jun 12, 2009 at 8:58 PM


Was there a pre-requisite that I needed to install for the scheduler to work? - No there are no pre-requisite.

Do you have any exceptions in the eventlog?

Download DebugView ( to view the adaapter trace events.

I still recommend to make sure the connection is working using a separate tool.


Jun 12, 2009 at 11:29 PM

Thanks for your help!  I was able to get it to work.

turns out there are two places to handle scheduling and I only configured the more detailed one.

once I configured the "outer" scheduling piece everything started working.  thanks!