This project has moved. For the latest updates, please go here.

Installed v1.5, freezing / hanging connections issues remain...

Feb 28, 2014 at 5:41 PM
We installed the v1.5 adapter into our dev environment late last year. We had been suffering through the freezing / hanging connections issues for some time with the previous versions. After installing v1.5, we continue to have the same issues. We have tried various different permeations with the configuration, to no avail. What else can we look at to help carve out and eliminate this bug?
Feb 28, 2014 at 9:12 PM
How often does it happen?
Are there any patterns, such as after a certain time or after it has been idle for an hour?
Do you have,or could you install Visual Studio for debugging?
What version of BizTalk are you running?

Sent from my Windows Phone

Feb 28, 2014 at 9:50 PM
I have to say, for the most part this adapter is pretty cool and once we found it, filled a niche, so, kudos (apart from the freezing connections fun and awesomeness)! Really Appreciate the reply, thank you...

Timing: Have not found a specific timing as of yet.

Pattern: Out of 30 SFTP related ports, it will happen to one this hour, and then it will happen to another two hours later. Two different types of connections (internal vs external). Have not found a pattern as of yet.

Visual is installed, so good to go there.

Version: BTS 2009

Blogical Adapter: v1.5.0

Applications associated with these situations are not full fledge BTS apps, they are rcv port(s) and associated snd port(s).
Feb 28, 2014 at 11:51 PM
Does it only happen for some ports, or does it seem random.
Where are you at. I'm in Australia at the moment.

Sent from my Windows Phone

Mar 1, 2014 at 12:24 AM
The west coast of the states.

The ports that have the issues all attach to Linux / Unix systems to shuttle data. There are numerous rcv and snd ports, from numerous different directories on each system. Some of these ports pickup one file a day, some pickup/snd thousands per hour. The situation this morning, happened to be a port that picks up once per day. I was able to pull up a process tcpview, and see the connections to the box. And could see that connection open, opened a process explorer, and could see the file hooks out there, nothing else of value. Restarted the port, dropped the connection, and voila file picked up like a machine. Been shuttling test files ever since to pound the port, no fails.

A while back while using v1.4, we had a connection that became stable last year. Just worked... Then the external entity unrelated to us that both provides us data and we send them data, upgraded their SFTP (linux based) packages and the port became completely unstable, to the point we were having to restart the port several times a day, which I think you can agree, is not a good way to operate. We have another external entity that we know are running a windows based SFTP solution, and their connections just, well, run.
Mar 1, 2014 at 12:44 AM
As you might already know, this bug has been around for a while. I've been wanting to fix it, but has never been able to reproduce the behaviour. I was very happy to learn that Greg Sharp had resolved the issue, so I added him to the team. I'm not convinced this is actually the same issue, although the symptoms seems similar.
It's of course impossible to resolve over email, but if you like, I might be able to resolve it remotely. Let me know if you're interested and we can set up a call.


Sent from Windows Mail

Mar 3, 2014 at 5:33 PM
I am very interested in a call. Lets get something scheduled...

Just as an example, on friday, we had two more locks, one Saturday, and nothing since. In our dev environment, I am working with the tools mentioned before, to see if I can capture something, however this is something I have done in the past without complete success.
Mar 4, 2014 at 12:42 AM
Please send me a private message using the codeplex site or shoot me an email at [my codeplex [email removed]. I’ll respond back with my Skype and Phone number.


Sent from Windows Mail