This project has moved and is read-only. For the latest updates, please go here.

The adapter "SFTP" raised an error message. Details "Requested registry access is not allowed."

Aug 7, 2008 at 8:49 PM
I'm using SFTP adapter in my current project and I just install it in a virtual machine with windows 2003 server r2 32 bit and it works smoothly. I have a development server (also a virtual machine) running in windows 2003 server r2 64 bit in which I installed SFTP adapter and it seemed the installation went fine. In my biztalk application, I have 2 bindings: (1) for ports located in the local folder in the local drive and (2) for ports connected to the SFTP site.

Here is the situation, first I used the bindings with the local ports and from there I modify those ports to be connected to the SFTP site and it works fine. The application runs smoothly picking and dropping files properly to the SFTP site. Now I tried to export the bindings with SFTP ports and i works fine too. I tried to switch back to the bindings for the local folder in the local drive for my testing locally. Now when I switched to the port binding by importing the bindings with SFTP site I created, then I encountered the error : 

The adapter "SFTP" raised an error message. Details "Requested registry access is not allowed."

And my application cannot pick-up and drop files to the SFTP site. But when I switch back into local folder bindings and manually changed again those ports connected to SFTP site, then it works fine. But switching to local and SFTP by importing the binding never worked and it returned the above message in the event log stack trace. I also noticed and compare the installation to my working virtual machine and the development server that in the development server registry there is no BLogical key under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Eventlog but in my working virtual machine I have this key. Can someone help me with this issue or encountered this issue before?
Oct 23, 2009 at 10:08 PM

I know this was a while ago, but were you ever able to get this resolved?  If so, how?  Thanks.

Oct 24, 2009 at 7:59 PM

This might be because the adapter tries to add the Blogical event source in the eventlog, and doesn't have required rights. You can resolve this by temporarly adding your BizTalk service account to Administrator group. After the event source has been created, you can just remove it  from the group.



Oct 26, 2009 at 2:48 PM

Thank you.  That was the resolution.  I see errors in the application event log now.  No more Blogical event log?