This project has moved. For the latest updates, please go here.

SFTP Adapter hangs under large workload

Jun 12, 2009 at 10:12 AM

Hello All,

I have downloaded the latest version of the Adapter. Now in normal circumstances the adapter works fine. However, when the workload increases to 2000+ file figure, the SFTP session hangs. Has anybody faced similar issues? Is there any workaround to this?


Thanks,

Sukal

Coordinator
Jun 12, 2009 at 8:02 PM

2000+ files per what? What is you polling intervall? What't the average file size?

If the batch gets to big, you might want to throttle using files per batch or batch size.

HTH 

//Mikael

Jun 13, 2009 at 5:24 AM

Hello Mikael,

This is how our conifigurations look like:

Number of file batch = 10

Polling interval = 30 secs

Avg. File size = 180kb

We have 6 receive locations polling for different file extensions from the same SFTP location. When the batch size(no of files in SFTP loc.) increases to 2000+, the operations seem to slow down and then hangs.

Thanks,

Sukal

Coordinator
Jun 16, 2009 at 12:16 PM

I'm not sure this would help, but it's worth a try:

The Receive handler will pick up a batch of files every 30 sec. For as long as the batch is full (in this case 10 files) it will continue to pull for more files. Try to increase to Polloing interval to 1-2 minutes. And prehaps increase the files in batch. 10 is small.

//Mikael 

Jun 17, 2009 at 11:11 AM

Hi Sukal, Mikael,

I think this is the same issue I face when using multiple receive locations polling for different file extensions. Please see the post - NullReferenceException on multiple receive locations

Sukal, could you please check the EventLog and tell us what errors you are getting.

Regards,

Amit

Jun 23, 2009 at 6:38 AM

Hello Mikael,

 

Thank you for your reply. Increasing polling interval to 120 & File batch to 20 solved  the problem for us. However, we are facing issues on the send port now. There is no option to set the polling interval or the File batch on the send port. How do I go about load balancing on this port?

I am currently testing with a single Send Port.

Connection Limit: 20

 

Thanks,

Sukal

 

Coordinator
Jun 23, 2009 at 1:46 PM
Edited Jun 23, 2009 at 1:48 PM

Seams to be a limit on the server side. To confirm this, apply "in order delivery". That way only one connection will be open at the time. This might flood your messagebox, so it wont be a good practice if you have a constant flow of many messages. But I'd like to know if it solves your problem.

If it works, deselect "in order delivery", and limit the "Connetion Limit" to 5.

//Mikael