This project has moved and is read-only. For the latest updates, please go here.

Add adapter in BizTalk 2013

Nov 25, 2013 at 10:14 AM
Installing the msi on a BizTalk 2013 server works, but adding the adapter is not possible.
The error "Cannot add adapter because of a duplicate Alias value. (WinMgmt)" is thrown.

In BizTalk 2013 there is already an SFTP adapter present. This still lacks some functionality (temp names while writing for instance). Hence installation of this one is still required.

Are there any solutions or workarounds for this issue?
Nov 26, 2013 at 5:57 AM
You don't need to register the adapter with an alias of SFTP. You can register using another alias. I have used BlogicalSFTP before without any problems.
Nov 26, 2013 at 3:15 PM
Even if you change it during registration when adding new adapter it doesn't Work. I Think it is due to AliasesXML (SFTP://) and other registry entries which are not unique. Perhaps Blogical SFTP can be changed to BSFTP so it is easier for users to add it?

REG_SZ : <AdapterAliasList><AdapterAlias>BSFTP://</AdapterAlias></AdapterAliasList>
Nov 27, 2013 at 1:41 AM
Can you remove/unregister the Microsoft SFTP adapter from the adapters collection first? Or, do you want to run the Blogical and Microsoft SFTP adapters in parallel?
Nov 27, 2013 at 1:47 AM
I don't want to do that as I want to leave defaults in case it affects future updates of inbox SFTP adapter. I also want to be able to run both in parallel to do performance tests, test against different FTP servers, and be able to import binding configurations from other BizTalk 2013 servers which has the inbox version.
Jul 10, 2014 at 6:50 PM
Edited Jul 10, 2014 at 6:58 PM
Was there a solution to this issue? I cannot remove the default biztalk SFTP adapter. I need to run these in parallel.

EDIT: Nevermind. I edited the registry entry mentioned in the post above.
Jul 11, 2014 at 10:48 PM
No change so far for it to work automatically.

There are some adjustments though to make it work in parallel when having the inbox SFTP also installed (by default in BizTalk 2013). Here is how to do this:
  • Install it :
  • Change this registry value from SFTP to BSFTP to not interfere with BizTalk inbox SFTP adapter (we already have SFTP adapter so need another name):
----BSFTP.reg start--------
Windows Registry Editor Version 5.00


----BSFTP.reg end--------
  • Add adapter in BizTalk admin console with BSFTP prefix (to distinguish between them)
  • Convert key to OpenSSH format (Blogical adapter use this format instead of Putty PPK format. I believe your key was imported from OpenSSH format already so perhaps you have this format still, else convert it back). You can convert with PuttyGen tool from Putty.
  • Configure receive location with OpenSSH key
Jul 21, 2014 at 5:59 PM
I found the registry from your previous post and made the required edits. Everything worked great. Thx for this post.

Phillip Thomson
cell 210.482.9945
home 210-492.1411
[email removed]