This project has moved and is read-only. For the latest updates, please go here.

Failed to create receive adapter - related to x64 Biztalk?

May 4, 2011 at 7:38 PM

I've installed and configured the adapter without issue, and I've added a send port to my application and configured the port. When I attempt to transmit through the send port though, I get this exception:

The Messaging Engine failed to create the receive adapter "Blogical Sftp v1".  InboundAssemblyPath: "C:\Program Files\Blogical\Blogical.Shared.Adapters.Sftp\Blogical.Shared.Adapters.Sftp.dll"  InboundTypeName: "Blogical.Shared.Adapters.Sftp.SftpReceiver"   Exception Details: "Could not load file or assembly 'file:///C:\Program Files\Blogical\Blogical.Shared.Adapters.Sftp\Blogical.Shared.Adapters.Sftp.dll' or one of its dependencies. The system cannot find the file specified." 

The odd thing, though, is that the adapters are installed to "C:\Program Files (x86)" as it's an x64 box - the files exist in that folder, but for some reason it's checking for them in the main "C:\Program Files" folder, where they're not located. Though I have Biztalk x64 installed, currently only the x86 send/receive/orchestration instances are running, and the bLogical adapter is only set up to use the x86 send/receive host instances. Am I missing something obvious here? Since I'm only using the 32-bit host instances, everything that's getting done should be with x86 components, but Biztalk seems opposed to letting me load and use this adapter.

Any ideas?

May 6, 2011 at 6:12 PM

same issue for me.  Anyone have a fix?

Tried adding assemblies to the GAC - Blogical.Shared.Adapters.Common.dll works, but Blogical.Shared.Adapters.Sftp.dll is not strongly named. 

Tried copying files to program files, but get the same exact error even with the files there. 

Tried registering the dll with c:\windows\sysWOW64\regsvr32 "C:\Program Files (x86)\Blogical\Blogical.Shared.Adapters.Sftp\Blogical.Shared.Adapters.Sftp.dll" and c:\windows\system32\regsvr32 "C:\Program Files (x86)\Blogical\Blogical.Shared.Adapters.Sftp\Blogical.Shared.Adapters.Sftp.dll" but get:

The module "C:\Program Files (x86)\Blogical\Blogical.Shared.Adapters.Sftp\Blogical.Shared.Adapters.Sftp.dll" was loaded but the entry-point DllRegisterServer was not found.
Make sure that "C:\Program Files (x86)\Blogical\Blogical.Shared.Adapters.Sftp\Blogical.Shared.Adapters.Sftp.dll" is a valid DLL or OCX file and then try again.

Tried using 32-bit Host Instances or 64-bit host instances - same message as rwmnau.