This project has moved and is read-only. For the latest updates, please go here.

Unable to connect to Sftp host

Nov 26, 2010 at 6:39 PM

I have been using the adapter for some time on a windows 2008 server. However, for some reason, the adapter started to fail. I started t oget the error below. Not sure why, I installed it on a windows 2003 server and it works like a charm. For whatever reason, I am not able to connect with a windows 2008. I looked at all the settings that I can think of and nothing seems to work. I uninstalled and re-installed the latest version of the adapter and nothing. For whatever reason, I keep getting the ecxact same error. I have tried to turn on and off the load balancing and nothing. Again, I have duplicated the same settings from the windows 2003 server to the 2008 server and I can not get the 2008 server to work. Have you seen this behavior before? Any help is greatly appreciated.

Method: Blogical.Shared.Adapters.Sftp.SharpSsh.Sftp.Dir
Error: Unable to connect to Sftp host []

Type: System.Exception
Target: Void connect(Boolean)
Message: Unable to connect to Sftp host []
   at Blogical.Shared.Adapters.Sftp.SharpSsh.Sftp.connect(Boolean force)
   at Blogical.Shared.Adapters.Sftp.SharpSsh.Sftp.reConnect()
   at Blogical.Shared.Adapters.Sftp.SharpSsh.Sftp.Dir(String fileMask, String uri, ArrayList filesInProcess, Boolean trace)

Type: Tamir.SharpSsh.jsch.JSchException
Target: Void connect(Int32)
Message: Auth fail
   at Tamir.SharpSsh.jsch.Session.connect(Int32 connectTimeout)
   at Tamir.SharpSsh.SshBase.ConnectSession(Int32 tcpPort)
   at Tamir.SharpSsh.SshBase.Connect(Int32 tcpPort)
   at Blogical.Shared.Adapters.Sftp.SharpSsh.Sftp.connect(Boolean force)

Dec 6, 2010 at 7:59 AM

Sorry for the late reply...

I haven't seen this before, but I'd recommend having a look at the log file on the ssh server. If you can't get the ssh log file, try install winSSHd on a separate box, and connect to that one as winSSHd is pretty verbose.


Dec 6, 2010 at 8:14 AM

hi Catorres,

I have installed the WinSSH server on a different Win 2008 machine. My adapter is on a second Win 2008 machine. I had no connection issues to start with, so you may be missing something.

You may check the firewall if it is blocking on the server hosting WinSSH. Second, I got exceptions when I removed permission to Login to the SFTP (Just as a test). It worked when I just gave the Login and file transfer permission. I removed the other permissions for the user registered. Third, I registered the user connecting there.. that way, I haven't given any user password in the adapter configuration. So, in the adapter screen, I just give the userid (registered on the server), the name of the private key file, the password to decrypt the private key (or whatever it does with it).

When I removed that user from the list of registered users, and alternatively gave the userid and pwd, it didn't work for me.. Not sure.. if it is the way it is supposed to be.

--> Praveen.

Dec 7, 2010 at 2:30 PM

Thank you both for the reply. I will check again to see if there is something that is missing. Not sure why this started to happen. It was working fine before, and all of the sudden this started to happen. If I find a resolution, I will post it here. Thank you all and have a great day.