This project has moved. For the latest updates, please go here.

Wells Fargo SAFE-Transmission

May 24, 2010 at 10:16 PM
Hi, Is there anybody else out there integrating to Wells Fargo SAFE-Transmission with the BizTalk SFTP adapter? I'm having two big problems. The first problem is that I can't download a file bigger than 20K in size. I tested that I can download larger files from other SFTP vendors through the adapter but not from Wells Fargo. Also, if I send an incorrect password, the adapter gets stuck in a loop and attempts to reconnect over a 1000 times a minute. After three failed attempts, Wells Fargo locks out our account. If the password fails, I'd like the adapter to write the failure to the event log and quit after the first failure. Please let me know if you are experiencing the same issues and if there are solutions. I have a workaround for the download issue in a Winscp script but it is not ideal. Any help would be much appreciated. Richard.
Coordinator
May 25, 2010 at 9:37 AM

I'm don't know about the 20K problem, but we are working on the re-connect issue. It has been posted already: http://sftpadapter.codeplex.com/Thread/View.aspx?ThreadId=60384&ANCHOR#Post437336

Thanks

//Mikael

May 25, 2010 at 2:04 PM
Hi Mikael, thanks for the update on the re-connect issue. I also re-produced the 20K issue with the jsch Java libraries. I suspect this issue was created when the code was ported from jsch to .NET. I'm going to supply Wells Fargo the code that reproduces the 20K. Right now, Wells Fargo are stating that the BizTalk adapter is not fully compatible with their systems. Cheers, Richard.
Coordinator
Aug 31, 2010 at 11:15 AM

The issue with re-connection on Auth failure has been resolved in the 1.3.7 version which should be released early September 2010.

//Mikael

Mar 9, 2011 at 3:51 PM

We also were having an issue with Wells Fargo and large files.  It has to do with the request_len that you send to them in the get method of the ssh librarys. 

Inside of ChannelSftp.cs in the SharpSSH\jsch directory look for the following lines.

 request_len=buf.buffer.Length-13;
 if(server_version==0){ request_len=1024; }

Underneath that we need to override the request_len, but just for Wells Fargo

I did it like this

string serverName = session.getHost();
if (serverName.ToUpper().Contains("WELLSFARGO"))
{
 request_len = 16384 - 13;//(16*1024)-13

The largest window that I could get to consistently work was 16384.  I tried (32*1024)-13, but it would only work part of the time.  The safest setting would be 1024, but then you take a performance hit.

Hope this helps someone.  I spent a couple of days trying to track this little beauty down.