This project has moved. For the latest updates, please go here.

Hi traffic due to continual Authentication requests to remote host.

Apr 16, 2010 at 12:01 AM

Hi,

Our infrastructure team has determined that the BizTalk Server which has the Blogical sFTP v1.3 adapter installed is continuously sending authentication requests every 1-2 seconds to the sFTP remote server causing extremely high network traffic over the course of a day. The Receive Locations, there are 5, are set up on a Time schedule of every 60 minutes.

Any Idea why it is continually sending authentication requests against the remote host so frequently.

Thanks

Coordinator
Apr 16, 2010 at 7:06 AM

 Interesting, can't really see how that is possible, other than if you have a lot of files to pick up and you've set the Batch file limit to 1. The adapter scheduler doesn't do anything on the receive port when it's while idle. You could verify this by enabling the Trace flag and using Debug View to see what is happening. Do you have any sendports? How did your infrastructure team come to this conclusion?

Let me know if you can't figure it out. I'd happy to help you out.

//Mikael

 

Apr 16, 2010 at 8:37 AM
How do I enable the trace flag. I will use debugView as you have suggested.

Thanks

Sent from my iPhone

On 16/04/2010, at 5:08 PM, "wmmihaa" <notifications@codeplex.com> wrote:

From: wmmihaa

Interesting, can't really see how that is possible, other than if you have a lot of files to pick up and you've set the Batch file limit to 1. The adapter scheduler doesn't do anything on the receive port when it's while idle. You could verify this by enabling the Trace flag and using Debug View to see what is happening. Do you have any sendports? How did your infrastructure team come to this conclusion?

Let me know if you can't figure it out. I'd happy to help you out.

//Mikael

Apr 19, 2010 at 12:36 AM

Hi,

Did what you suggest and sure enough I can see what was happening.

There is a particular directory where our client places files. They seem to be dropping 0 byte files into this directory and this was up to 95 files. This seemed to trigger the adapter every second (see trace below)

[8528] [SftpReceiverEndpoint] PickupFilesAndSubmit called [SFTP://192.168.93.1:22/cluster/user/bs/Production/LIS/Outbound/PO_*.csv]

[8528] [SftpReceiverEndpoint] Dir(/cluster/user/bs/Production/LIS/Outbound/PO_*.csv)

[8528] [SftpReceiverEndpoint] Found 95 files.

Once I deleted the 95 files the continuous activity then stopped. Then by putting back a single 0 byte file on the next cycle (10 mins) it went crazy again until I deleted the file manually from the folder.

Is this a bug in the adapter of is there a setting I can set to ignore 0 byte files

Thanks

From: wmmihaa [mailto:notifications@codeplex.com]
Sent: Friday, 16 April 2010 5:07 PM
To: Jody Petroni
Subject: Re: Hi traffic due to continual Authentication requests to remote host. [SftpAdapter:209505]

From: wmmihaa

Interesting, can't really see how that is possible, other than if you have a lot of files to pick up and you've set the Batch file limit to 1. The adapter scheduler doesn't do anything on the receive port when it's while idle. You could verify this by enabling the Trace flag and using Debug View to see what is happening. Do you have any sendports? How did your infrastructure team come to this conclusion?

Let me know if you can't figure it out. I'd happy to help you out.

//Mikael

Read the full discussion online.

To add a post to this discussion, reply to this email (SftpAdapter@discussions.codeplex.com)

To start a new discussion for this project, email SftpAdapter@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com

Coordinator
Apr 19, 2010 at 5:01 PM

Ok, that is really unfortunate, and I'd consider it a bug. I'll look into it when I got time

//Mikael

Coordinator
Apr 19, 2010 at 10:15 PM

I've uploaded a new version (1.3.5) where I've fixed "your" problem. Thanks for making us aware of this bug!

//Mikael

Apr 19, 2010 at 11:03 PM

Thankyou,

To install do I just run the msi and accept the defaults (ie overwriting existing version dll’s) and then restart the host?

Thanks

From: wmmihaa [mailto:notifications@codeplex.com]
Sent: Tuesday, 20 April 2010 8:15 AM
To: Jody Petroni
Subject: Re: Hi traffic due to continual Authentication requests to remote host. [SftpAdapter:209505]

From: wmmihaa

I've uploaded a new version (1.3.5) where I've fixed "your" problem. Thanks for making us aware of this bug!

//Mikael

Read the full discussion online.

To add a post to this discussion, reply to this email (SftpAdapter@discussions.codeplex.com)

To start a new discussion for this project, email SftpAdapter@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com

Coordinator
Apr 21, 2010 at 6:15 AM

That should work for you. Let me know if you have any issues. If it's urgent use IM through my blog.

//Mikael